Internet Explorer And “Unsupported Browser” Warnings

ieunsupported1

Lately I’ve seen an increase in the number of web sites warning that I’m running an unsupported version of Internet Explorer, or recommending that I upgrade to the latest version. In some cases, the web sites refuse to load at all. Autotask, for example, will not go past this screen because it “does not support the browser you are using.”

ieunsupported2

I’ve had clients see that warning in the last few weeks at bank web sites (it appeared recently for one client logging into Exchange Bank), at Martindale for lawyers, at some Google services – Google Calendar, for example – and many others.

If you’re running Windows 7 or 8, Internet Explorer is up to date and all web sites should support your browser. Click on the gear in the upper right, then click on “About Internet Explorer” to check the browser version. You’ll see one of these versions:

—  Internet Explorer 9 is more than two years old, rock solid, and should be the minimum IE version on every Windows 7 computer.

—  Internet Explorer 10 was released a year ago. Most Windows 7 computers have been upgraded to IE10 and it shipped with Windows 8. By this time, all web sites should work with IE10.

—  Internet Explorer 11 is being finalized now. An early version was released with the Windows 8.1 preview a few months ago, and the final version will ship in October with the final release of Windows 8.1. Last week Microsoft released a preview of Internet Explorer 11 for Windows 7.

You should not have to care about these things. The “unsupported browser” messages are annoying. Although some people criticized IE in the past, it is widely agreed that Internet Explorer has matured into a browser that is fast, secure, and standard. There are no drastic changes in these versions that should cause anything to stop working.

Older versions of Internet Explorer (6/7/8) or Chrome or Firefox may not be able to run programs needed for some websites to work correctly, so websites that provide services typically include a bit of code that checks to make sure you are using a browser they support. The problem seems to occur when a web site has not been updated to expect a new IE version – your browser reports IE10 and the web site thinks, “I only recognize the names IE8 and IE9, so this unfamiliar version must be really old.”

If you run into this problem and you can’t proceed to the website, there are really only two things to do.

One is to load the website in Internet Explorer’s Compatibility View, which attempts to set back IE to emulate an earlier version. You may see a little icon in the address bar to turn on Compatibility View, or you can find it by clicking on the gear in the upper right / Compatibility View Settings.

iecompatibilityview

The other option is to use Google Chrome to visit that site. Google Chrome has its own problems! Personally I find it to be complex and mystifying, like many Google products. But it comes in handy to access the websites that won’t display in IE – just as IE is helpful to view the websites that won’t display correctly in Chrome.

Leave a Reply

Your email address will not be published. Required fields are marked *